Author Topic: OxygenBasic Compiler Test  (Read 1207 times)

0 Members and 1 Guest are viewing this topic.

Arnold

  • Sr. Member
  • ****
  • Posts: 468
OxygenBasic Compiler Test
« on: January 28, 2015, 08:20:18 AM »
Hi Charles,

I have created some small batch files in order to compile the demos with gxo2.exe or co2.exe. CompileTest.bat is the main file. Maybe the path of gxo2.exe must be adapted in the batch file. To run the batch file will need about 10 minutes (with some interactions). It will create a lot of exe files, so I deleted the folder of OxygenBasic and made a fresh install afterwards.

The purpose is to find out which programs do not compile correctly. I have added the results for Windows Vista 32bit using the Oxygenbasic Build of January 28 2015 02:06.

The project does not try to verify the results of the demos. But maybe it could be of some help nevertheless. Some of the errors should result because of a stricter syntax of Oxygenbasic? Some demos with macro errors did run interpreted with gxo2.exe. One program crashed gxo2.exe. One demo (C switch) showed the error: file not found, but when I omit the blank in the filename then Cswich.o2bas will compile. Sometimes there are really tiny errors e.g. $\inc\ instead of "$\inc\".

I tried to compile the demos with co2.exe too, but co2.exe only displays numbers in the case of error messages.


Roland

.
« Last Edit: February 24, 2015, 02:38:51 AM by Arnold »

Charles Pegge

  • Author
  • *****
  • Posts: 3282
    • Oxygen Basic
Re: OxygenBasic Compiler Test
« Reply #1 on: January 28, 2015, 03:48:28 PM »
Roland,

Many thanks for your compile lists.

I have fixed the co2 compiler error reporting, and I am working through the breakages. Some of the examples need to be removed or rewitten, rather than repaired.

Arnold

  • Sr. Member
  • ****
  • Posts: 468
Re: OxygenBasic Compiler Test
« Reply #2 on: January 29, 2015, 09:16:43 AM »
Hi Charles,

maybe this could be of some interest too. If I use the latest O2hBuild of Jan 29 2015, I now  get the same results using gxo2.exe and co2.exe. There is one exception though:

compiling \ProjectsA\OpenGlCns\c1WIP.o2bas with gxo2.exe creates a different error message than with co2.exe (see attachments)

BTW if I try in a dos window in C:\OxygenBasic\projectsA\OpenglCns this command:

c:\OxygenBasic\co2.exe -c -m c1WIP.o2bas

no output is shown at all, whereas gxo2.exe -c -m shows the same output as when redirected to a file.

However I am not sure if this is of any importance at all. When I load the file in SciTe which uses gxo2 or in OxIde which uses co2 and execute c1WIP.o2bas I get the same message:

ERROR:Not found membrane.sc
WORD:   16
LINE:       189
FILE:main source
PASS:   2

This message is different from the compiler output in this case and is more helpful anyway.


Roland

.

Charles Pegge

  • Author
  • *****
  • Posts: 3282
    • Oxygen Basic
Re: OxygenBasic Compiler Test
« Reply #3 on: January 29, 2015, 10:46:42 AM »

Hi Roland,

Anything tagged WIP (work In Progress) is not usually in a working state. In this case, it is a branch from SurfaceFormula.o2bas. I think it has no further use and can be thrown out.

co2 seems to be working as expected.